Reply
 
Thread Tools Display Modes
Old 18-04-2015, 07:49 PM   #1
R34TARD
Senior Member
 
R34TARD's Avatar
 
Exclamation R34 GT-T Clutch issues! HELP!

Hey guys... Long time since I've been on here... hopefully the BS has died down cos I'd love to come back! Anyways... looking for some brain storming!

so.... The clutch on my R34 GT-T burnt out. Finally got around to getting a new one. So... The 34 clutch is a pull type clutch. I purchased a brand new Xtreme clutch. It is a single carbon plate rated for 600hp. I'll cut it down to simple facts to help with trouble shooting. When we put it in, had a slight bit of clutch shudder but drove fine. BUT the bite point was really high. The other day on full throttle it started slipping. Then recently it started slipping on about half or a third throttle. Now I'm trying to figure out why a brand new clutch would be slipping.... so here are the facts...
I am looking for ideas as to why it would be slipping.

-Dad (qualified mechanic) and I, put the clutch in.
-Yes, we washed the oil off the pressure plate before putting it in.
-Approx 100kms on the new clutch (not much I know)
-We thought it was no freeplay on the clutch. Spent today adjusting the master cylinder push rod. it was originally flush with the gold 'U' plate in this picture. Then we brought it all the way out. Still slipping. Then we brought it to where it is in the picture and that's the best so far but it's still slipping.



So looking for ideas on why it's still slipping? Thanks guys!
R34TARD is offline   Reply With Quote


Sponsored Links
Advertisement
 
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes


» Recent Threads
No Threads to Display.

Copyright 2010 Aussie Street Cars. All rights reserved.
All times are GMT +8. The time now is 04:41 PM.
Powered by vBulletin. Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by vBadvanced CMPS v3.2.2